USB Suddenly Is Write Protected and Can't Format or Delete Files

My SanDisk Ultra 32GB stick suddenly shows The disk is write-protected I tried the Diskpart command and Regedit.exe, but nothing worked. I want to remove the Read Only and Write Protected designations from the USB.

Best Answered by

Dany· Answered on Feb 03, 2023

After trying some methods and getting no positive results, you should know that your SanDisk Ultra 32GB stick will be encrypted and kept secure if BitLocker is enabled on your USB drive. You'll need a password or recovery key to turn off BitLocker for a USB stick, and you will need to reformat the hard drive if you have no other options. How to turn off BitLocker on a USB stick and remove write protection in Windows? Activate "File Explorer" and check for the storage device there. If the symbol had a padlock, BitLocker was turned on for the USB stick. Then, you can right-click the symbol to bring up the context menu and choose "Manage BitLocker." This action launches the BitLocker Drive Encryption window, and you can check the encrypted storage devices here. Finally, you should right-click the protected SanDisk USB device and choose "Turn off BitLocker" to disable BitLocker. Before entering the recovery key, enter the password or make another selection.

After removing the write protection of your SanDisk Ultra USB stick, you can format the USB normally. If you don't want to lose data, remember to back up your files in advance. Or you can download a Windows data recovery tool to retrieve lost files. EaseUS Data Recovery Wizard is a good choice for Windows users, and you can use this tool to recover files from a USB flash drive, SSD, HDD, SD card, and memory card. Whether you lost personal photos or working documents, EaseUS Data Recovery Wizard will help you a lot.

Use EaseUS Data Recovery Wizard to recover deleted or lost files easily and quickly.

Tutorials on how to recover lost, deleted, or formatted data from HDD, SSD, USB, SD card, or other storage media on Windows and Mac.